智能车制作

 找回密码
 注册

扫一扫,访问微社区

QQ登录

只需一步,快速开始

查看: 358|回复: 11

[硬件类] 电机驱动

[复制链接]

2

主题

6

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
302
威望
119
贡献
69
兑换币
76
注册时间
2018-7-26
在线时间
60 小时
发表于 2019-2-23 22:48:12 | 显示全部楼层 |阅读模式
看智能车制作上的电机驱动电路,做出来后只有左电机能转,指示灯不接电机自己会亮。。。
file:///C:/Users/admin/AppData/Roaming/Tencent/Users/634312850/QQ/WinTemp/RichOle/%7DC1_F]XRCZ8AWQF4QA1LFGH.png


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复

使用道具 举报

6

主题

34

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
497
QQ
威望
238
贡献
145
兑换币
150
注册时间
2018-11-14
在线时间
57 小时
发表于 2019-2-27 22:24:23 | 显示全部楼层
解决没???我驱动不接电机,指示灯也会自己亮,不插单片机,或把信号线拔掉就好了,找不到解决办法,你们的那个是什么原因???
回复 支持 反对

使用道具 举报

2

主题

6

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
302
威望
119
贡献
69
兑换币
76
注册时间
2018-7-26
在线时间
60 小时
 楼主| 发表于 2019-2-28 18:41:35 | 显示全部楼层
逐梦杨帆 发表于 2019-2-27 22:24
解决没???我驱动不接电机,指示灯也会自己亮,不插单片机,或把信号线拔掉就好了,找不到解决办法,你们 ...

指示灯自己会亮可能是电容放电的问题
回复 支持 反对

使用道具 举报

6

主题

34

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
497
QQ
威望
238
贡献
145
兑换币
150
注册时间
2018-11-14
在线时间
57 小时
发表于 2019-2-28 18:50:58 | 显示全部楼层
我把电容拆了,给主板通电,驱动开关不开,但是驱动上灯还是亮的。我查过开关没有短路:L:L
回复 支持 反对

使用道具 举报

6

主题

34

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
497
QQ
威望
238
贡献
145
兑换币
150
注册时间
2018-11-14
在线时间
57 小时
发表于 2019-2-28 18:52:31 | 显示全部楼层
你那个只有左电机能转是怎么解决的???
回复 支持 反对

使用道具 举报

2

主题

6

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
302
威望
119
贡献
69
兑换币
76
注册时间
2018-7-26
在线时间
60 小时
 楼主| 发表于 2019-2-28 19:25:14 | 显示全部楼层
逐梦杨帆 发表于 2019-2-28 18:52
你那个只有左电机能转是怎么解决的???

发现不是只有左电机能转,而是pwm3有问题,具体还没找到
回复 支持 反对

使用道具 举报

6

主题

34

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
497
QQ
威望
238
贡献
145
兑换币
150
注册时间
2018-11-14
在线时间
57 小时
发表于 2019-2-28 19:36:19 | 显示全部楼层
Mrone 发表于 2019-2-28 19:25
发现不是只有左电机能转,而是pwm3有问题,具体还没找到

那就是有一侧电机只能单向转是吧????
回复 支持 反对

使用道具 举报

6

主题

34

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
497
QQ
威望
238
贡献
145
兑换币
150
注册时间
2018-11-14
在线时间
57 小时
发表于 2019-2-28 19:42:06 | 显示全部楼层
Mrone 发表于 2019-2-28 19:25
发现不是只有左电机能转,而是pwm3有问题,具体还没找到

你这个是驱动上的问题,还是主板上的问题???
回复 支持 反对

使用道具 举报

2

主题

6

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
302
威望
119
贡献
69
兑换币
76
注册时间
2018-7-26
在线时间
60 小时
 楼主| 发表于 2019-2-28 19:43:00 | 显示全部楼层
逐梦杨帆 发表于 2019-2-28 19:42
你这个是驱动上的问题,还是主板上的问题???

驱动板,希望超哥翻我的牌子
回复 支持 反对

使用道具 举报

6

主题

34

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
497
QQ
威望
238
贡献
145
兑换币
150
注册时间
2018-11-14
在线时间
57 小时
发表于 2019-2-28 19:46:59 | 显示全部楼层
Mrone 发表于 2019-2-28 19:43
驱动板,希望超哥翻我的牌子

我们的驱动板也是这个问题一直没有解决
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

关于我们|联系我们|小黑屋|智能车制作 ( 京ICP备14023231号-8

GMT+8, 2019-3-21 13:53 , Processed in 0.134224 second(s), 30 queries , Gzip On.

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表